Goal: Configure the core WLAN infrastructure (West and East Coast)
- Configure basic IP connectivity.
- Configure high-availability (HA).
West Coast Data Center 1
Note: The East Coast Dater Center configuration is identical except for IP addressing.
westdc9800-1/westdc9800-2
*************************************************************************************
hostname <INSERT HOSTNAME>
!
line con 0
logg sync
!
ip name-server 10.0.206.7
ip domain name netprojekralac.com
!
enable password Cisco123
!
user-name lab
creation-time 1699425847
privilege 15
password 0 Cisco123
!
*************************************************************************************
vlan 7
name "WIRELESS-MGMT***
!
wireless management interface vlan 348
!
interface Loopback0
no ip address
!
interface GigabitEthernet1
switchport trunk native vlan 1
switchport mode trunk
negotiation auto
no mop enabled
no mop sysid
shutdown
!
interface GigabitEthernet2
switchport trunk native vlan 1
switchport mode trunk
negotiation auto
no mop enabled
no mop sysid
!
interface Vlan1
no ip address
shutdown
no mop enabled
no mop sysid
!
interface Vlan7
ip address 10.0.48.48 255.255.255.192
no mop enabled
no mop sysid
!
ip route 0.0.0.0 0.0.0.0 10.0.48.1
!
*************************************************************************************
wireless mobility group name WESTCOAST-MOBILITY-1
wireless rf-network WEST-COAST-RF-GROUP
!
ntp server 10.0.0.4
!
*************************************************************************************
ap dot11 5ghz shutdown
!
ap dot11 24ghz shutdown
!
wireless country US
!
*************************************************************************************
Configure the wireless trustpoint - only required on the Cisco 9800-CL
wireless config vwlc-ssc key-size 2048 signature-algo sha256 password 0 Cisco123
!
*************************************************************************************
Configure High Availability on westdc9800-1 and westdc9800-2
- Verify chassis on both devices
Change the chassis priority and chassis number
westdc9800-1#chassis 1 priority 2
westdc9800-2#chassis 1 renumber 2
WARNING: Changing the switch number may result in a configuration change for that switch. The interface configuration associated with the old switch number will remain as a prov isioned configuration. New Switch Number will be effective after next reboot. Do you want to continue?[y/n]? [yes]: yes
westdc9800-2#
- Reload both devices
- Verify the chassis settings on both devices before proceeding
westdc9800-1
westdc9800-2
Note: The Cisco 9800-CL utilizes the GigabitEthernet3 as the redundancy port (RP).
westdc9800-1#chassis redundancy ha-interface gigabitEthernet 3
WARNING: Changing the switch HA interface may result in a configuration change for that switch. The configuration associated with the old switch HA interface will remain as a provisioned configuration. New HA interface will be effective after next reboot. Do you want to continue?[y/n]? [yes]: yes
westdc9800-1#
****************************************************************************************************
westdc9800-2#chassis redundancy ha-interface gigabitEthernet 3
WARNING: Changing the switch HA interface may result in a configuration change for that switch. The configuration associated with the old switch HA interface will remain as a provisioned configuration. New HA interface will be effective after next reboot. Do you want to continue?[y/n]? [yes]: yes
westdc9800-2#
****************************************************************************************************
Configure redundancy between westdc9800-1 and westdc9800-2
westdc9800-1
(config)#redun-management interface vlan 7 chassis 1 address 10.0.0.47 chassis 2 address 10.0.0.46
westdc9800-2
(config)#redun-management interface vlan 7 chassis 1 address 10.0.0.47 chassis 2 address 10.0.0.46
Reload the primary controller first, then immediately reload the secondary controller
HA mode verification
westdc9800-1
westdc9800-2
Enable Default Gateway Check Configuration
management gateway failover enable
management gateway-failover interval 12
Verify IP reachability between West and East WLCs
westdc9800-1#ping 10.0.0.18
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.18, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/3 ms
westdc9800-1#ping 10.0.0.24
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.24, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/2 ms
westdc9800-1#ping 10.0.0.25
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.25, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms
westdc9800-1#