DMVPN Notes – Phase 2 Static Mappings

  • For dynamic spoke-to-spoke tunnels to form, the spokes require multipoint tunnels.
  • Static entries for the hub are required on the spoke. Without the static entries, the NHRP registration cannot be sent.

DMVPN Phase 2 with static mapping restrictions:

  • Summarization is not allowed on the hub.
  • Default routing is not allowed on the hub.
  • The spoke must always maintain next-hope reachability.
R5 Hub
R5(config-if)#do show run int t2023 

interface Tunnel2023
 ip address 172.16.0.5 255.255.255.0
 no ip redirects
 ip mtu 1476
 ip nhrp map 172.16.0.1 169.1.100.1
 ip nhrp map 172.16.0.2 169.1.100.2
 ip nhrp map 172.16.0.3 169.1.100.3
 ip nhrp map 172.16.0.4 169.1.100.4
 ip nhrp network-id 5023
 ip tcp adjust-mss 1436
 tunnel source 169.1.100.5
 tunnel mode gre multipoint
R1
R1#show run int t2023

interface Tunnel2023
 ip address 172.16.0.1 255.255.255.0
 no ip redirects
 ip nhrp map 172.16.0.2 169.1.100.2
 ip nhrp map 172.16.0.3 169.1.100.3
 ip nhrp map 172.16.0.4 169.1.100.4
 ip nhrp map 172.16.0.5 169.1.100.5
 ip nhrp network-id 1023
 tunnel source Ethernet0/0.100
 tunnel mode gre multipoint
 ip mtu 1476
 ip tcp adjust-mss 1436
R2
R2(config-if)#do show run int t2023

interface Tunnel2023
 ip address 172.16.0.2 255.255.255.0
 no ip redirects
 ip nhrp map 172.16.0.5 169.1.100.5
 ip nhrp map 172.16.0.4 169.1.100.4
 ip nhrp map 172.16.0.3 169.1.100.3
 ip nhrp map 172.16.0.1 169.1.100.1
 ip nhrp network-id 2023
 tunnel source 169.1.100.2
 tunnel mode gre multipoint
 ip mtu 1476
 ip tcp adjust-mss 1436
end
R3

R3(config-if)#do show run int t2023

interface Tunnel2023
 ip address 172.16.0.3 255.255.255.0
 no ip redirects
 ip mtu 1476
 ip tcp adjust-mss 1436
 ip nhrp map 172.16.0.5 169.1.100.5
 ip nhrp map 172.16.0.4 169.1.100.4
 ip nhrp map 172.16.0.2 169.1.100.2
 ip nhrp map 172.16.0.1 169.1.100.1
 ip nhrp network-id 2023
 tunnel source 169.1.100.3
 tunnel mode gre multipoint
end
R4
R4(config-if)#do show run int t2023

interface Tunnel2023
 ip address 172.16.0.4 255.255.255.0
 no ip redirects
 ip mtu 1476
 ip tcp adjust-mss 1436
 ip nhrp map 172.16.0.5 169.1.100.5
 ip nhrp map 172.16.0.3 169.1.100.3
 ip nhrp map 172.16.0.2 169.1.100.2
 ip nhrp map 172.16.0.1 169.1.100.1
 ip nhrp network-id 2023
 tunnel source 169.1.100.4
 tunnel mode gre multipoint
end

Verification of mappings

R5#show dmvpn 
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
        N - NATed, L - Local, X - No Socket
        T1 - Route Installed, T2 - Nexthop-override
        C - CTS Capable
        # Ent --> Number of NHRP entries with same NBMA peer
        NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
        UpDn Time --> Up or Down Time for a Tunnel
==========================================================================

Interface: Tunnel2023, IPv4 NHRP Details 
Type:Spoke, NHRP Peers:4, 

 # Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
 ----- --------------- --------------- ----- -------- -----
     1 169.1.100.1          172.16.0.1  NHRP    never    SC
     1 169.1.100.2          172.16.0.2  NHRP    never    SC
     1 169.1.100.3          172.16.0.3  NHRP    never    SC
     1 169.1.100.4          172.16.0.4  NHRP    never    SC
R5#show ip nhrp 

172.16.0.1/32 via 172.16.0.1
   Tunnel2023 created 00:23:02, never expire 
   Type: static, Flags: 
   NBMA address: 169.1.100.1 
172.16.0.2/32 via 172.16.0.2
   Tunnel2023 created 00:23:02, never expire 
   Type: static, Flags: 
   NBMA address: 169.1.100.2 
172.16.0.3/32 via 172.16.0.3
   Tunnel2023 created 00:23:02, never expire 
   Type: static, Flags: 
   NBMA address: 169.1.100.3 
172.16.0.4/32 via 172.16.0.4
   Tunnel2023 created 00:23:02, never expire 
   Type: static, Flags: 
   NBMA address: 169.1.100.4 

R1, R2, R3 and R4 will have similar mappings



Verify reachability between R1 and the other spokes

R1#tclsh
R1(tcl)#foreach VAR {
+>(tcl)# 172.16.0.1 
+>(tcl)# 172.16.0.2 
+>(tcl)# 172.16.0.3 
+>(tcl)# 172.16.0.4 
+>(tcl)# 172.16.0.5
+>(tcl)#} { puts [exec "ping  $VAR"] }

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/5 ms

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/3 ms

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

R1(tcl)#
R1(tcl)#tclquit
R1#
R1#traceroute 172.16.0.4
Type escape sequence to abort.
Tracing the route to 172.16.0.4
VRF info: (vrf in name/id, vrf out name/id)
  1 172.16.0.4 7 msec *  3 msec
R1#

With DMVPN Phase 2 static mappings, the spokes can directly communicate with each other.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.