EIGRP Basic Config

R5


!
interface Tunnel2023
 ip address 172.16.0.5 255.255.255.0
 no ip redirects
 ip mtu 1476
 ip nhrp map multicast dynamic
 ip nhrp network-id 555
 ip nhrp registration timeout 10
 ip nhrp redirect
 ip tcp adjust-mss 1436
 tunnel source Ethernet0/0.100
 tunnel mode gre multipoint
end

router eigrp CWNE387
 !
 address-family ipv4 unicast autonomous-system 387
  !
  af-interface Tunnel2023
   no split-horizon
  exit-af-interface
  !
  topology base
  exit-af-topology
  network 5.1.1.5 0.0.0.0
  network 5.1.2.5 0.0.0.0
  network 150.1.5.5 0.0.0.0
  network 172.16.0.5 0.0.0.0
 exit-address-family
R5#

R1

interface Tunnel2023
 ip address 172.16.0.1 255.255.255.0
 no ip redirects
 ip mtu 1476
 ip nhrp map 172.16.0.5 169.1.100.5
 ip nhrp map multicast 169.1.100.5
 ip nhrp network-id 111
 ip nhrp nhs 172.16.0.5
 ip nhrp registration timeout 5
 ip nhrp shortcut
 ip tcp adjust-mss 1436
 tunnel source 169.1.100.1
 tunnel mode gre multipoint
end

router eigrp CWNE387
 !
 address-family ipv4 unicast autonomous-system 387
  !
  topology base
  exit-af-topology
  network 1.1.1.1 0.0.0.0
  network 1.1.2.1 0.0.0.0
  network 150.1.1.1 0.0.0.0
  network 172.16.0.1 0.0.0.0
 exit-address-family
R1#

R2

interface Tunnel2023
 ip address 172.16.0.2 255.255.255.0
 no ip redirects
 ip mtu 1476
 ip nhrp map 172.16.0.5 169.1.100.5
 ip nhrp map multicast 169.1.100.5
 ip nhrp network-id 222
 ip nhrp nhs 172.16.0.5
 ip nhrp registration timeout 5
 ip nhrp shortcut
 ip tcp adjust-mss 1436
 tunnel source 169.1.100.2
 tunnel mode gre multipoint
end

router eigrp CWNE387
 !
 address-family ipv4 unicast autonomous-system 387
  !
  topology base
  exit-af-topology
  network 2.0.0.0
  network 150.1.0.0
  network 172.16.0.0
  network 172.16.0.2 0.0.0.0
 exit-address-family

R3

interface Tunnel2023
 ip address 172.16.0.3 255.255.255.0
 no ip redirects
 ip mtu 1476
 ip nhrp map 172.16.0.5 169.1.100.5
 ip nhrp map multicast 169.1.100.5
 ip nhrp network-id 333
 ip nhrp nhs 172.16.0.5
 ip nhrp registration timeout 5
 ip nhrp shortcut
 ip tcp adjust-mss 1436
 tunnel source 169.1.100.3
 tunnel mode gre multipoint
end

router eigrp CWNE387
 !
 address-family ipv4 unicast autonomous-system 387
  !
  topology base
  exit-af-topology
  network 3.0.0.0
  network 150.1.0.0
  network 172.16.0.0
 exit-address-family

R4

!
interface Tunnel2023
 ip address 172.16.0.4 255.255.255.0
 no ip redirects
 ip mtu 1476
 ip nhrp map 172.16.0.5 169.1.100.5
 ip nhrp map multicast 169.1.100.5
 ip nhrp network-id 444
 ip nhrp nhs 172.16.0.5
 ip nhrp registration timeout 5
 ip nhrp shortcut
 ip tcp adjust-mss 1436
 tunnel source 169.1.100.4
 tunnel mode gre multipoint
end

router eigrp CWNE387
 !
 address-family ipv4 unicast autonomous-system 387
  !
  topology base
  exit-af-topology
  network 4.0.0.0
  network 150.1.0.0
  network 172.16.0.0
 exit-address-family

Verification

R1#tclsh
R1(tcl)#
R1(tcl)#foreach VAR {
+>(tcl)#
+>(tcl)#1.1.1.1 
+>(tcl)#1.1.2.1 
+>(tcl)#2.1.1.2 
+>(tcl)#2.1.2.2 
+>(tcl)#3.1.1.3 
+>(tcl)#3.1.2.3 
+>(tcl)#5.1.1.5 
+>(tcl)#5.1.2.5 
+>(tcl)#150.1.2.2
+>(tcl)#150.1.3.3
+>(tcl)#150.1.4.4
+>(tcl)#
+>(tcl)#} { puts [exec "ping $VAR"] }

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/10 ms

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.1.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/3/5 ms

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.1.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/7 ms

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.1.2.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/5 ms

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.1.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/5/14 ms

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.1.2.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/2 ms

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.1.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/8 ms

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.1.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/4 ms

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.1.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/3/4 ms

R1(tcl)#tclquit
R1#

tclsh

foreach VAR {

1.1.1.1 
1.1.2.1 
2.1.1.2 
2.1.2.2 
3.1.1.3 
3.1.2.3 
5.1.1.5 
5.1.2.5 
150.1.2.2
150.1.3.3
150.1.4.4

} { puts [exec "ping $VAR"] }
tclquit

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.