Cisco 9800 (17.1)HA via Nexus 9K vPC

Posted on Posted in Cisco 9800 HA via vPC, Cisco 9800 Wireless

Nexus Config – 9K1

vlan 1,10,20
vlan 10
name NETWORK_MGMT
vlan 20
name WLAN_MGMT

spanning-tree vlan 1-3967 priority 24576
vrf context management
vpc domain 1
peer-keepalive destination 1.1.1.2 source 1.1.1.1

interface Vlan1
no ip redirects
no ipv6 redirects

interface Vlan10
no shutdown
no ip redirects
ip address 192.168.100.2/26
no ipv6 redirects
ip router eigrp LAB

interface Vlan20
no shutdown
ip address 192.168.200.2/26
ip router eigrp LAB
vrrp 20
priority 254
address 192.168.200.1
no shutdown

interface port-channel12
switchport mode trunk
switchport trunk allowed vlan 1,10,20
spanning-tree port type network
vpc peer-link

interface port-channel777
switchport mode trunk
vpc 777

interface port-channel778
switchport mode trunk
vpc 778

interface Ethernet1/1
switchport mode trunk
channel-group 777 mode active

interface Ethernet1/2
switchport mode trunk
channel-group 778 mode active

interface Ethernet1/3
switchport mode trunk
switchport trunk allowed vlan 1,10,20
channel-group 12 mode active

interface Ethernet1/4
switchport mode trunk
switchport trunk allowed vlan 1,10,20
channel-group 12 mode active

interface Ethernet1/5
shutdown
switchport mode trunk

interface mgmt0
vrf member management
ip address 1.1.1.1/30
line console
line vty
router eigrp LAB
address-family ipv4 unicast
autonomous-system 100


Nexus Config – 9K2

vlan 1,10,20
vlan 10
name NETWORK_MGMT
vlan 20
name WLAN_MGMT

spanning-tree vlan 1-3967 priority 28672
vrf context management
vpc domain 1
peer-keepalive destination 1.1.1.1 source 1.1.1.2

interface Vlan1
no ip redirects
no ipv6 redirects

interface Vlan10
no shutdown
no ip redirects
ip address 192.168.100.3/26
no ipv6 redirects
ip router eigrp LAB

interface Vlan20
no shutdown
ip address 192.168.200.3/26
ip router eigrp LAB
vrrp 20
priority 150
address 192.168.200.1
no shutdown

interface port-channel12
switchport mode trunk
switchport trunk allowed vlan 1,10,20
spanning-tree port type network
vpc peer-link

interface port-channel777
switchport mode trunk
vpc 777

interface port-channel778
switchport mode trunk
vpc 778

interface Ethernet1/1
switchport mode trunk
channel-group 778 mode active

interface Ethernet1/2
switchport mode trunk
channel-group 777 mode active

interface Ethernet1/3
switchport mode trunk
switchport trunk allowed vlan 1,10,20
channel-group 12 mode active

interface Ethernet1/4
switchport mode trunk
switchport trunk allowed vlan 1,10,20
channel-group 12 mode active

interface Ethernet1/5
shutdown
switchport mode trunk

interface mgmt0
vrf member management
ip address 1.1.1.2/30

interface loopback0
ip address 192.168.255.1/32
ip router eigrp LAB
line console
line vty
router eigrp LAB
address-family ipv4 unicast
autonomous-system 100


Verify vPC on Nexus1


Verify vPC on Nexus2


Verify HA and etherchannel on both WLCs

Primary Controller


Standby Controller

By default the console of the standby controller is disabled


To enable the console on the standby you have to do it on the active controller



The console of the standby controller should now be accessible


Force a switchover from the active to standby controller


The standby controller should now be active








Leave a Reply

Your email address will not be published. Required fields are marked *